您的位置:首页 > 其它

N!

2015-08-18 15:36 483 查看


N!




Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^


题目描述

首先很感谢刘老师能给我这次机会给大家出题,希望大家做完题后能有所收获,如果有任何问题还请海涵,毕竟出套题不容易……TAT

题目整体不难,大体是给我带的大一新生出题的难度,所以请各位放心。

If you want to learn something from other people, remember, stay hunger.---shadow95

Now, your first problem comes~

This task is very simple, please calculate how many zeros are there at the end of calculation of n!.

For example, 15! = 1307674368000, so answer is 3.

输入

At the first line, there is a number T indicating the number of test cases.

Then, following T lines, each line there is a number n (n<10^9).

输出

For each case, output the case number and answer in one line.

示例输入

3
5
100
1024


示例输出

Case #1: 1
Case #2: 24
Case #3: 253


提示

来源

HDU shadow95

示例程序

view plaincopyprint如果您复制代码时出现行号,请点击左边的“view
plain”后再复制

#include<stdio.h>

#include<string.h>

int fun(int n)

{

int sum=0;

while(n)

{

n=n/5;

sum+=n;

}

return sum;

}

int main()

{

int t, T, n;

scanf("%d", &T);

for(int t=1;t<=T;t++)

{

scanf("%d", &n);

int re=fun(n);

printf("Case #%d: %d\n", t, re);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: