您的位置:首页 > 其它

(树分块) bzoj 1086

2015-05-15 14:03 106 查看

1086: [SCOI2005]王室联邦

Time Limit: 10 Sec Memory Limit: 162 MBSec Special Judge
Submit: 730 Solved: 403
[Submit][Status][Discuss]

Description

“余”人国的国王想重新编制他的国家。他想把他的国家划分成若干个省,每个省都由他们王室联邦的一个成员来管理。他的国家有n个城市,编号为1..n。一些城市之间有道路相连,任意两个不同的城市之间有且仅有一条直接或间接的道路。为了防止管理太过分散,每个省至少要有B个城市,为了能有效的管理,每个省最多只有3B个城市。每个省必须有一个省会,这个省会可以位于省内,也可以在该省外。但是该省的任意一个城市到达省会所经过的道路上的城市(除了最后一个城市,即该省省会)都必须属于该省。一个城市可以作为多个省的省会。聪明的你快帮帮这个国王吧!

Input

第一行包含两个数N,B(1<=N<=1000, 1 <= B <= N)。接下来N-1行,每行描述一条边,包含两个数,即这条边连接的两个城市的编号。

Output

如果无法满足国王的要求,输出0。否则输出数K,表示你给出的划分方案中省的个数,编号为1..K。第二行输出N个数,第I个数表示编号为I的城市属于的省的编号,第三行输出K个数,表示这K个省的省会的城市编号,如果有多种方案,你可以输出任意一种。

Sample Input

8 2

1 2

2 3

1 8

8 7

8 6

4 6

6 5

Sample Output

3

2 1 1 3 3 3 3 2

2 1 8
块状树啊,ORZZZZpoQQQQ大爷

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<string>
using namespace std;
#define maxn 1005
int n,b;
int head[maxn],tot=1,root[maxn],belong[maxn],top,cnt,stk[maxn];
struct node
{
int to,next;
}e[2*maxn];
void add(int u,int v)
{
++tot;
e[tot].to=v;
e[tot].next=head[u];
head[u]=tot;
}
void dfs(int u,int father)
{
int bottom=top;
for(int i=head[u];i;i=e[i].next)
{
int v=e[i].to;
if(v==father)
continue;
dfs(v,u);
if(top-bottom>=b)
{
root[++cnt]=u;
while(top!=bottom)
{
belong[stk[top--]]=cnt;
}
}
}
stk[++top]=u;
}
int main()
{
scanf("%d%d",&n,&b);
for(int i=1;i<n;i++)
{
int x,y;
scanf("%d%d",&x,&y);
add(x,y);
add(y,x);
}
dfs(1,-1);
while(top)
{
belong[stk[top--]]=cnt;
}
printf("%d\n",cnt);
for(int i=1;i<=n;i++)
{
printf("%d%c",belong[i],i==n?'\n':' ');
}
for(int i=1;i<=cnt;i++)
{
printf("%d%c",root[i],i==cnt?'\n':' ');
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: