您的位置:首页 > 其它

hdoj_1285_拓扑排序

2014-02-07 10:27 113 查看


确定比赛名次

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9383 Accepted Submission(s): 3659



Problem Description

有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。

Input

输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。

Output

给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。

Sample Input

4 3
1 2
2 3
4 3


Sample Output

1 2 4 3
#include <iostream>
#include <cstdio>
#include <vector>
#include <stack>
#include <queue>
#include <functional>
#include <cstring>
using namespace std;

int n, m;
int res[510], num = 0;
int temp[510], ru[510];
vector<vector<int> >v;

struct cmp
{
bool operator() (int &a, int &b)
{
return a > b;
}
};

priority_queue<int, vector<int>, cmp>s;

void topsort()
{
for (int i = 1; i <= n; i++)
{
temp[i] = ru[i];
if (temp[i] == 0)
s.push(i);
}
while (!s.empty())
{
int t = s.top();
res[num++] = t;
s.pop();
for (int i = 0; i < v[t].size(); i++)
if (--temp[v[t][i]] == 0)
s.push(v[t][i]);
}

}

int main()
{
while (scanf("%d%d", &n, &m) !=EOF)
{
memset(res, 0, sizeof(res));
memset(temp, 0, sizeof (temp));
memset(ru, 0, sizeof(ru));
num = 0;
v.clear();
v.resize(n + 5);
for (int i = 1; i <= n; i++)
v[i].assign(n + 5, 0);
while (m--)
{
int a, b;
scanf("%d%d", &a, &b);
if(v[a][b] == 0)
{
ru[b]++;
v[a].push_back(b);
}
}
topsort();
printf("%d", res[0]);
for (int i = 1; i < n; i++)
printf(" %d", res[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: