您的位置:首页 > 其它

poj 2253 Frogger(dijkstra)

2013-07-26 13:01 411 查看
Frogger

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20903 Accepted: 6786
Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her
by jumping. 

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's
stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line
after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source

Ulm Local 1997

解题报告:

读了好久才把题目看懂,就是一只青蛙要从图上的一个点跳到另一个点,问最小通路的最大跳跃距离。
实际就是求无向图中两个点的通路中最小的最大边的长度。

代码:

#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
#define maxn  0x7ffffff
double dis[1005][1005],len[1005];
int n,vis[1005];

struct point
{
int x,y;
}p[1005];

double max(double a,double b)
{
return a>b?a:b;
}
void dijkstra()
{
double min;
int cnt;
memset(vis,0,sizeof(vis));
for(int i=0;i<n;i++)
len[i]=dis[0][i];
vis[0]=1;
for(int i=1;i<n;i++)
{
min=maxn,cnt=-1;
for(int j=0;j<n;j++)
if(!vis[j]&&min>len[j])
{
cnt=j;
min=len[j];
}

if(cnt==-1) break ;
vis[cnt]=1;
for(int j=0;j<n;j++)
if(vis[j]==0&&len[j] > max(len[cnt],dis[cnt][j]))
len[j] = max(len[cnt],dis[cnt][j]);
}
}
int main()
{
int num=0;
while(scanf("%d",&n),n)
{
for(int i=0;i<n;i++)
scanf("%d%d",&p[i].x,&p[i].y);
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
dis[i][j]=sqrt(1.0*(p[i].x-p[j].x)*(p[i].x-p[j].x)+1.0*(p[i].y-p[j].y)*(p[i].y-p[j].y));
dijkstra();
printf("Scenario #%d\nFrog Distance = %.3lf\n\n",++num,len[1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  图论 最短路 dijkstra