您的位置:首页 > 其它

HDOJ 1001 Sum Problem

2015-07-10 21:10 106 查看

Sum Problem

Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 339300 Accepted Submission(s): 85485



[align=left]Problem Description[/align]
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

[align=left]Input[/align]
The input will consist of a series of integers n, one integer per line.

[align=left]Output[/align]
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

[align=left]Sample Input[/align]

1
100


[align=left]Sample Output[/align]

1

5050


[align=left]Author[/align]
DOOM III

[align=left]Recommend[/align]
We have carefully selected several similar problems for you: 1002 1090 1003 1091 1004

正确但超时码:

#include<stdio.h>
int main(){
while(EOF){
int n,i,num=0;
scanf("%d",&n);
for(i=1;i<=n;i++)
num+=i;
printf("%d\n\n",num);
}
return 0;
}
用公式AC:

用整型还超时,必须得用double型,我也是服惹
#include<stdio.h>
int main(){
double n;
while(scanf("%lf",&n)!=EOF)
printf("%.0lf\n\n",n*(n+1)/2);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: