您的位置:首页 > 其它

The sum problem

2012-02-16 19:11 120 查看

The sum problem

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7877 Accepted Submission(s): 2422


[align=left]Problem Description[/align]
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

[align=left]Input[/align]
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

[align=left]Output[/align]
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

[align=left]Sample Input[/align]

20 10 50 30 0 0

[align=left]Sample Output[/align]

[1,4] [10,10]
[4,8] [6,9] [9,11] [30,30]

#include<stdio.h>
#include<math.h>
int main()
{
int n, m;
while( scanf( "%d %d", &n, &m ) && (n||m) )
{
int max, i, result;
max = sqrt( m*2.0 );
for( i = max; i > 0; --i )
{
result = m - ( i*i + i )/2;
if( result % i == 0 )
{
printf( "[%d,%d]\n", result/i+1, result/i+i );
}
}
printf( "\n" );
}
}


这题早就推了公式,只是可能有些地方没有简化,一直出不来,然后今天看了白神的代码,知道了解题思路,首先,把i看作0, 则可求出i的最大值,然后暴力i。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: