您的位置:首页 > 其它

poj1007 -- DNA Sorting

2017-04-02 22:08 309 查看
DNA Sorting

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 100566 Accepted: 40371
Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is
greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can
be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT


Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

思路就是创建一个结构体保存数据,求出每一个DNA的measure,然后根据measure从小到大排序,最后输出。
代码如下:

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <string>
#include <vector>
using namespace std;

struct Node
{
string DNA;
int measure;

Node(string str,int mea):DNA(str),measure(mea){}
};

bool cmp(Node node1,Node node2) //按measure从小到大排序
{
return node1.measure<node2.measure;
}

vector<Node> v;

int main()
{
//freopen("test.txt","r",stdin);
v.clear();
int n,m;
scanf("%d%d",&n,&m);
while(m--)
{
string str;
cin>>str;
int measure=0;
int len=str.length();
for(int i=0;i<len-1;i++)
{
for(int j=i+1;j<len;j++)
{
if(str[i]>str[j])
measure++;
}
}
Node node(str,measure);
v.push_back(node);
}
sort(v.begin(),v.end(),cmp);
for(int i=0;i<v.size();i++)
cout<<v[i].DNA<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj