您的位置:首页 > 其它

PAT-A1136/B1079 A Delayed Palindrome/延迟的回文数 题目内容及题解

2019-02-11 11:48 204 查看

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​⋯a​1​​a​0​​ with 0≤a​i​​<10 for all i and a​k​​>0. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

给定一个 k+1 位的正整数 N,写成 a​k​​⋯a​1​​a​0​​ 的形式,其中对所有 i 有 0≤a​i​​<10 且 a​k​​>0。N 被称为一个回文数,当且仅当对所有 i 有 a​i​​=a​k−i​​。零也被定义为一个回文数。

非回文数也可以通过一系列操作变出回文数。首先将该数字逆转,再将逆转数与该数相加,如果和还不是一个回文数,就重复这个逆转再相加的操作,直到一个回文数出现。如果一个非回文数可以变出回文数,就称这个数为延迟的回文数。(定义翻译自 https://en.wikipedia.org/wiki/Palindromic_number )

给定任意一个正整数,本题要求你找到其变出的那个回文数。

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

输入在一行中给出一个不超过1000位的正整数。

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

对给定的整数,一行一行输出其变出回文数的过程。每行格式如下:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

其中 A 是原始的数字,B 是 A 的逆转数,C 是它们的和。A 从输入的整数开始。重复操作直到 C 在 10 步以内变成回文数,这时在一行中输出 C is a palindromic number.;或者如果 10 步都没能得到回文数,最后就在一行中输出 Not found in 10 iterations.。

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

解题思路

  1. 分别建立检查字符串是否回文、翻转字符串和字符串内容相加(包含输出中间过程)的函数;
  2. 以字符串形式读入待检查数字;
  3. 检查合格则输出,否则执行字符串相加,并计数;
  4. 循环到合格或达到十次后输出结果;
  5. 返回零值。

代码

[code]#include<stdio.h>
#include<string.h>
#define maxn 1050
char ans[maxn],re[maxn],sum[maxn];

int check (char a[]){
int left=0,right=strlen(a)-1;
while(left<right){
if(a[left]!=a[right]){
return 0;
}
left++;
right--;
}
return 1;
} //1对称

void Reverse(char a[],char b[]){
int i=0,len=strlen(a)-1;
while(len>=0){
b[i++]=a[len];
len--;
}
b[i]=0;
return;
}

void Add(){
int i=0,c=0,num;
Reverse(ans,re);
while(ans[i]!=0){
num=re[i]+ans[i]-2*'0'+c;
c=num/10;
sum[i++]=num%10+'0';
}
if(c){
sum[i++]='1';
}
sum[i]=0;
printf("%s + %s = ",ans,re);
Reverse(sum,ans);
printf("%s\n",ans);
}

int main(){
int N=0;
scanf("%s",ans);
while(1){
if(check(ans)){
printf("%s is a palindromic number.\n",ans);
return 0;
}
Add();
N++;
if(N>=10){
break;
}
}
printf("Not found in 10 iterations.\n");
return 0;
}

运行结果

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: