您的位置:首页 > 其它

PAT-A1137/B1080 Final Grading/MOOC期终成绩 题目内容及题解

2019-02-11 11:50 246 查看

For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G=(G​mid−term​​×40%+G​final​​×60%) if G​mid−term​​>G​final​​, or G​final​​ will be taken as the final grade G. Here G​mid−term​​ and G​final​​ are the student's scores of the mid-term and the final exams, respectively.

The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

对于在中国大学MOOC(http://www.icourse163.org/ )学习“数据结构”课程的学生,想要获得一张合格证书,必须首先获得不少于200分的在线编程作业分,然后总评获得不少于60分(满分100)。总评成绩的计算公式为 G=(G​mid−term​​×40%+G​final​​×60%),如果 G​mid−term​​>G​final​​;否则总评 G 就是 G​final​​。这里 G​mid−term​​ 和 G​final​​ 分别为学生的期中和期末成绩。

现在的问题是,每次考试都产生一张独立的成绩单。本题就请你编写程序,把不同的成绩单合为一张。

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

Then three blocks follow. The first block contains P online programming scores G​p​​'s; the second one contains M mid-term scores G​mid−term​​'s; and the last one contains N final exam scores G​final​​'s. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

输入在第一行给出3个整数,分别是 P(做了在线编程作业的学生数)、M(参加了期中考试的学生数)、N(参加了期末考试的学生数)。每个数都不超过10000。

接下来有三块输入。第一块包含 P 个在线编程成绩 G​p​​;第二块包含 M 个期中考试成绩 G​mid−term​​;第三块包含 N 个期末考试成绩 G​final​​。每个成绩占一行,格式为:学生学号 分数。其中学生学号为不超过20个字符的英文字母和数字;分数是非负整数(编程总分最高为900分,期中和期末的最高分为100分)。

Output Specification:

For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

打印出获得合格证书的学生名单。每个学生占一行,格式为:

StudentID G​p​​ G​mid−term​​ G​final​​ G

If some score does not exist, output "−1" instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID's. It is guaranteed that the StudentID's are all distinct, and there is at least one qullified student.

如果有的成绩不存在(例如某人没参加期中考试),则在相应的位置输出“−1”。输出顺序为按照总评分数(四舍五入精确到整数)递减。若有并列,则按学号递增。题目保证学号没有重复,且至少存在1个合格的学生。

Sample Input:

6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81

Sample Output:

missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84

解题思路

  1. 建立结构体储存学生成绩;
  2. 获取编程分,低于200分的直接跳过;
  3. 读取期中考试成绩,并记录(有编程分数记录者,否则直接弃掉),并记录其“有记录”;
  4. 读取期末考试成绩,并记录(有编程分数记录者,否则直接弃掉),并记录其“有记录”;
  5. 计算所有有记录学生的总分,并记录有效学生数;
  6. 按照题目要求排序;
  7. 按照题目要求输出,并返回零值。

代码

[code]#include<iostream>
#include<string>
#include<map>
#include<algorithm>
using namespace std;
#define maxn 10010

struct Student{
string name;
int Gp,Gmt,Gf,G;
int vividmt,vividf,vivid;
}stu[maxn];

map<string,int> mp;
int P,M,N,num=0;

bool cmp(Student a,Student b){
if(a.vivid!=b.vivid){
return a.vivid>b.vivid;
}else if(a.G!=b.G){
return a.G>b.G;
}else{
return a.name<b.name;
}
}

int main(){
int i,b,c,vnum=0;
string a;
cin>>P>>M>>N;
while(P--){
cin>>a>>b;
if(b<200){
continue;
}
if(mp.find(a)==mp.end()){
mp[a]=num;
stu[num].Gp=b;
stu[num].name=a;
num++;
}
}
while(M--){
cin>>a>>b;
if(mp.find(a)!=mp.end()){
c=mp[a];
stu[c].Gmt=b;
stu[c].vividmt=1;
}
}
while(N--){
cin>>a>>b;
if(mp.find(a)!=mp.end()){
c=mp[a];
stu[c].Gf=b;
stu[c].vividf=1;
}
}
for(i=0;i<num;i++){
if(stu[i].vividf){
if(stu[i].vividmt&&(stu[i].Gmt>stu[i].Gf)){
stu[i].G=(int)(0.4*stu[i].Gmt+0.6*stu[i].Gf+0.5);
}else{
stu[i].G=stu[i].Gf;
}
if(stu[i].G>=60){
stu[i].vivid=1;
vnum++;
}
}
}
sort(stu,stu+num,cmp);
for(i=0;i<vnum;i++){
a=stu[i].name;
cout<<a<<" "<<stu[i].Gp<<" ";
if(stu[i].vividmt){
cout<<stu[i].Gmt;
}else{
cout<<"-1";
}
cout&
28924
lt;<" "<<stu[i].Gf<<" "<<stu[i].G<<endl;
}
return 0;
}

运行结果

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: