您的位置:首页 > 其它

PAT-A1153/B1095 Decode Registration Card of PAT/解码PAT准考证 题目内容及题解

2019-02-13 08:43 471 查看

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

PAT 准考证号由 4 部分组成:

  • 第 1 位是级别,即 T 代表顶级;A 代表甲级;B 代表乙级;
  • 第 2~4 位是考场编号,范围从 101 到 999;
  • 第 5~10 位是考试日期,格式为年、月、日顺次各占 2 位;
  • 最后 11~13 位是考生编号,范围从 000 到 999。

现给定一系列考生的准考证号和他们的成绩,请你按照要求输出各种统计信息。

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​^4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

输入首先在一行中给出两个正整数 N(≤10​^4​​)和 M(≤100),分别为考生人数和统计要求的个数。

接下来 N 行,每行给出一个考生的准考证号和其分数(在区间 [0,100] 内的整数),其间以空格分隔。

考生信息之后,再给出 M 行,每行给出一个统计要求,格式为:类型 指令,其中

  • 类型 为 1 表示要求按分数非升序输出某个指定级别的考生的成绩,对应的 指令 则给出代表指定级别的字母;
  • 类型 为 2 表示要求将某指定考场的考生人数和总分统计输出,对应的 指令 则给出指定考场的编号;
  • 类型 为 3 表示要求将某指定日期的考生人数分考场统计输出,对应的 指令 则给出指定日期,格式与准考证上日期相同。

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

对每项统计要求,首先在一行中输出 Case #: 要求,其中 # 是该项要求的编号,从 1 开始;要求 即复制输入给出的要求。随后输出相应的统计结果:

  • 类型 为 1 的指令,输出格式与输入的考生信息格式相同,即 准考证号 成绩。对于分数并列的考生,按其准考证号的字典序递增输出(题目保证无重复准考证号);
  • 类型 为 2 的指令,按 人数 总分 的格式输出;
  • 类型 为 3 的指令,输出按人数非递增顺序,格式为 考场编号 总人数。若人数并列则按考场编号递增顺序输出。

如果查询结果为空,则输出 NA。

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

解题思路

  1. 初始化、读入数据,并分别按照等级、考场,日期等提前归类;
  2. 按照题目要求分别编制不同的输出函数;
  3. 根据请求的不同调用不同的输出函数进行输出;
  4. 输出完成后返回零值。

代码

[code]#include<cstdio>
#include<cstring>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;

#define maxn 10010
int N,M;
struct Person{
char ID[15];
int score;
};
struct Room{
int ID,num;
};
vector<Person> B,A,T;
int num[maxn],sum[maxn];
map<int,int> mp;
int seq=0;
vector<int> Datesum[maxn];

bool cmp1(Person a,Person b){
if(a.score!=b.score){
return a.score>b.score;
}else{
return strcmp(a.ID,b.ID)<0;
}
}

bool cmp2(Room a,Room b){
if(a.num!=b.num){
return a.num>b.num;
}else{
return a.ID<b.ID;
}
}

void Init(){
int i,j;
int site,score,date;
char str[15];
Person temp;
scanf("%d%d",&N,&M);
for(i=0;i<N;i++){
scanf("%s%d",str,&score);
//等级
strcpy(temp.ID,str);
temp.score=score;
switch(str[0]){
case 'B':{
B.push_back(temp);
break;
}
case 'A':{
A.push_back(temp);
break;
}
case 'T':{
T.push_back(temp);
break;
}
default:{
break;
}
}
//考场
site=0;
for(j=0;j<3;j++){
site=site*10+str[1+j]-'0';
}
num[site]++;
sum[site]+=score;
//日期
date=0;
for(j=0;j<6;j++){
date=date*10+str[4+j]-'0';
}
if(mp.find(date)!=mp.end()){
j=mp[date];
}else{
j=seq;
mp[date]=seq++;
}
Datesum[j].push_back(site);
}
sort(B.begin(),B.end(),cmp1);
sort(A.begin(),A.end(),cmp1);
sort(T.begin(),T.end(),cmp1);
}

void Print1(){
char C;
int i;
getchar();
scanf("%c",&C);
printf("%c\n",C);
switch(C){
case 'B':{
for(i=0;i<B.size();i++){
printf("%s %d\n",B[i].ID,B[i].score);
}
if(i==0){
printf("NA\n");
}
break;
}
case 'A':{
for(i=0;i<A.size();i++){
printf("%s %d\n",A[i].ID,A[i].score);
}
if(i==0){
printf("NA\n");
}
break;
}
case 'T':{
for(i=0;i<T.size();i++){
printf("%s %d\n",T[i].ID,T[i].score);
}
if(i==0){
printf("NA\n");
}
break;
}
default:{
printf("NA\n");
break;
}
}
return;
}

void Print2(){
int data;
scanf("%d",&data);
printf("%d\n",data);
if(num[data]==0){
printf("NA\n");
}else{
printf("%d %d\n",num[data],sum[data]);
}
return;
}

void Print3(){
int data,i;
Room temp;
vector<Room> R;
scanf("%d",&data);
printf("%06d\n",data);
if(mp.find(data)!=mp.end()){
data=mp[data];
sort(Datesum[data].begin(),Datesum[data].end());
R.clear();
temp.ID=Datesum[data][0];
temp.num=1;
for(i=1;i<Datesum[data].size();i++){
if(Datesum[data][i]==temp.ID){
temp.num++;
}else{
R.push_back(temp);
temp.ID=Datesum[data][i];
temp.num=1;
}
}
R.push_back(temp);
sort(R.begin(),R.end(),cmp2);
for(i=0;i<R.size();i++){
printf("%03d %d\n",R[i].ID,R[i].num);
}
}else{
printf("NA\n");
}
return;
}
int main(){
int i,ty;
Init();
for(i=1;i<=M;i++){
printf("Case %d: ",i);
scanf("%d",&ty);
printf("%d ",ty);
switch(ty){
case 1:{
Print1();
break;
}
case 2:{
Print2();
break;
}
case 3:{
Print3();
break;
}
}
}
return 0;
}

运行结果

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: