您的位置:首页 > 产品设计 > UI/UE

hdu 5916 Harmonic Value Description(思维)

2018-01-30 21:59 369 查看


Harmonic Value Description

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1481    Accepted Submission(s): 845
Special Judge


Problem Description

The harmonic value of the permutation p1,p2,⋯pn is

∑i=1n−1gcd(pi.pi+1)

Mr. Frog is wondering about the permutation whose harmonic value is the strictly k-th smallest among all the permutations of
.

 

Input

The first line contains only one integer T (1≤T≤100),
which indicates the number of test cases.

For each test case, there is only one line describing the given integers n and k (1≤2k≤n≤10000).

 

Output

For each test case, output one line “Case #x: p1 p2 ⋯ pn”,
where x is the case number (starting from 1) and p1 p2 ⋯ pn is
the answer.

 

Sample Input

2
4 1
4 2

 

Sample Output

Case #1: 4 1 3 2
Case #2: 2 4 1 3

 

Source

2016中国大学生程序设计竞赛(长春)-重现赛

 

Recommend

wange2014

题意:

有一个序列,序列里面的数是从1到n。定义了一个价值,它的计算方法为∑i=1n−1gcd(pi.pi+1)

问价值第k小的序列是怎么样的。

思路:

任意相邻的两个正整数都是互质的,gcd=1。而任意相邻的两个偶数之间gcd=2,任意相邻的两个奇数之间gcd=1。

所以构造第k小的序列其实只需要让k个相邻的偶数在序列中连续就行了。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int a[10005];
int main()
{
int t,n,k,cas=1;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&k);
if(n==1)
{
printf("Case #%d: 1\n",cas++);
}
else
{
for(int i=1;i<=n;i++)
a[i]=i;
printf("Case #%d:",cas++);
while(k>0)
{
for(int i=1;i<=n;i++)
{
if(k==0)
break;
if(a[i]%2==0)
{
for(int j=1;j<n;j++)
{
if(a[j]%2!=0)
{
swap(a[i],a[j]);
k--;
break;
}
}
}
}
}
for(int i=1;i<=n;i++)
{
printf(" %d",a[i]);
}
printf("\n");
}
}
return 0;
}

∑i=1n−1gcd(pi.pi+1)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: