您的位置:首页 > 产品设计 > UI/UE

hdu 5916 Harmonic Value Description 最大公约数

2017-09-09 20:24 411 查看

Harmonic Value Description

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 929    Accepted Submission(s): 544
Special Judge


[align=left]Problem Description[/align]
The harmonic value of the permutation
p1,p2,⋯pn
is

∑i=1n−1gcd(pi.pi+1)

Mr. Frog is wondering about the permutation whose harmonic value is the strictly k-th smallest among all the permutations of
.
 

[align=left]Input[/align]
The first line contains only one integer T (1≤T≤100),
which indicates the number of test cases.

For each test case, there is only one line describing the given integers n and k (1≤2k≤n≤10000).
 

[align=left]Output[/align]
For each test case, output one line “Case #x:
p1 p2 ⋯ pn”,
where x is the case number (starting from 1) and p1 p2 ⋯ pn
is the answer.
 

[align=left]Sample Input[/align]

2
4 1
4 2

 

[align=left]Sample Output[/align]

Case #1: 4 1 3 2
Case #2: 2 4 1 3

 

[align=left]Source[/align]
2016中国大学生程序设计竞赛(长春)-重现赛  

// CcpcTraining.cpp: 定义控制台应用程序的入口点。
//#include "stdafx.h"
#include<iostream>
using namespace std;

int main() {
int n, k, test;
cin >> test;
for (int cases = 1; cases <= test; cases++) {
cin >> n >> k;
cout << "Case #" << cases << ":";
cout << " " << 2 * k << " " << k;
for (int i = k + 1; i <= 2 * k - 1; i++) {
cout << " " << i;
}
for (int i = 2 * k + 1; i <= n; i++) {
cout << " " << i;
}
for (int i = 1; i <= k - 1; i++) {
cout << " " << i;
}
cout << endl;
}
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: