您的位置:首页 > 产品设计 > UI/UE

POJ 2533 Longest Ordered Subsequence(最长上升子序列O(n*n)解法)

2018-01-03 11:02 447 查看
Longest Ordered Subsequence

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions:56940 Accepted: 25509
Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN)
be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence
(1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8

Sample Output
4

dp[i]为以a[i]为最后一个元素所能组成的最长上升子序列,这样就保证了a[i]为此序列中的最大值

因此在递推时只需a[i]>a[j] 便一定能组成长度为a[j]+1的子序列

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
int n;
while (scanf("%d", &n) != EOF)
{
int dp[1002], a[1002];
for (int i = 1; i <= n; i++)
scanf("%d", &a[i]);
if (n == 1)
{
printf("1\n");
continue;
}
for (int j = 0; j <= 1000; j++)
dp[j] = 1;
int res=0;
for (int i = 2; i <= n; i++)
{
for (int j = 1; j < i; j++)
{
if (a[i] > a[j])
dp[i] = max(dp[i], dp[j] + 1);
}
res = max(dp[i], res);
}
printf("%d\n", res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐