您的位置:首页 > 产品设计 > UI/UE

POJ - 2533 Longest Ordered Subsequence —— 最长不连续上升子序列

2017-09-28 10:55 483 查看
Longest Ordered Subsequence

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 55404 Accepted: 24843
Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN)
be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence
(1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8

Sample Output
4


题意:给定n个数 要求找出最长的上升子序列 可以不连续

思路:不断更新最小的数 每次输入一个新的数就从前到后遍历找到比它大的数 没有就排到最后

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#define max_ 100010
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
int dp[1010];
int main(int argc, char const *argv[])
{
int n;
while(scanf("%d",&n)!=EOF)
{
memset(dp,-1,sizeof(dp));
int i,j,cnt=1;
for(i=1;i<=n;i++)
{
int x;
scanf("%d",&x);
for(j=1;j<=cnt;j++)
{
if(x<=dp[j])
{
dp[j]=x;
break;
}
}
if(j>cnt)
dp[++cnt]=x;
}
printf("%d\n",cnt-1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: