您的位置:首页 > 产品设计 > UI/UE

POJ 2533 Longest Ordered Subsequence 最长上升子序列

2013-04-09 23:27 501 查看
Longest Ordered Subsequence

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).
Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8


Sample Output

4

代码 :


/*都是代码 看着烦 来点 新东西
老大问过我…希不希望你还喜欢我…你知道我是怎么回答的吗…
被爱是一种幸福…可我希望你开心幸福…
*/
#include<cstdio>
#include<iostream>
using namespace std ;
#define M 1010
int a[M] , b[M] ;
int find( int s , int e , int w ){ // 二分查找 比 a[] 大或者相等的然后返回下标
if( s == e ) return s ;
int mid = ( s + e ) >> 1 ;
if( b[mid] < w )  return find( mid + 1 , e , w ) ;
else return find( s , mid , w ) ;
}
int main()
{
int i  , j , n , m ;
while(scanf( "%d" , &n ) != EOF ){
memset( b , 0  , sizeof(b) ) ;
for( i = 1 ;i <= n ;i++)
scanf( "%d" , &a[i] ) ;
b[0] = -200000 ; int len = 0 ;
for( i = 1 ;i <= n ;i++){
if( a[i] > b[len] ) j = ++len ;
else j = find( 1 , len , a[i] ) ;
b[j] = a[i] ; // 替换

}
cout << len << endl ;
}
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: