您的位置:首页 > 产品设计 > UI/UE

Longest Ordered Subsequence POJ - 2533(最长上升子序列)

2017-03-19 13:04 295 查看

Longest Ordered Subsequence

POJ - 2533

A numeric sequence of ai is ordered ifa1 <
a2 < ... < aN. Let the subsequence of the given numeric sequence (a1,
a2, ..., aN) be any sequence (ai1,
ai2, ..., aiK), where 1 <=
i1 < i2 < ... <iK <=
N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input
The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output
Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input
7
1 7 3 5 9 4 8

Sample Output
4


两种思路:

1.定义dp[i]为以ai为结尾的上升子序列,如果有j<i&&aj<ai那么一定存在dp[i]=max{1,dp[j]+1},利用这一递推公式可以在O(n^2)的时间内解决问题。

代码:
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;

const int manx=10000;

int s[5000];
int dp[5000];
int n;
void readin()
{
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&s[i]);
}
}
void Init()
{
memset(s,0,sizeof(s));
}
void solve()
{
int ans=0;
for(int i=0;i<n;i++)
{

dp[i]=1;
for(int j=0;j<i;j++)
{
if(s[i]>s[j])
{
dp[i]=max(dp[i],dp[j]+1);
}
}
ans=max(ans,dp[i]);
}
printf("%d\n",ans);
}
int main ()
{
Init();
readin();
solve();
return 0;
}

2.对于长度相同的子序列,末尾更小的序列会更有优势,所以再针对长度相同的情况下最小的末尾元素求解。

dp[i]=长度为i+1的上升子序列中的元素的最小值(不存在的话就是INF)
bd66
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#define INF 100000000
using namespace std;
const int manx=10000;
int s[5000];
int dp[5000];
int n;
void readin()
{
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&s[i]);
}
}
void Init()
{
memset(s,0,sizeof(s));
}
void solve()
{
int ans=0;
for(int i=0;i<n;i++)
{

dp[i]=1;
for(int j=0;j<i;j++)
{
if(s[i]>s[j])
{
dp[i]=max(dp[i],dp[j]+1);
}
}
ans=max(ans,dp[i]);
}
printf("%d\n",ans);
}
void solve1()
{
fill(dp,dp+n,INF);
for(int i=0;i<n;i++)
{
*(lower_bound(dp,dp+n,s[i]))=s[i];
}
printf("%d\n",lower_bound(dp,dp+n,INF)-dp);
}
int main ()
{
//    Init();
readin();
solve1();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: