您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树二:遍历二叉树

2017-11-07 21:24 197 查看

数据结构实验之二叉树二:遍历二叉树

Time Limit: 1000MS Memory Limit: 65536KB
[align=center]Submit Statistic[/align]

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

每组输入数据对应输出2行:

第1行输出中序遍历序列;

第2行输出后序遍历序列。

 

Example Input

abc,,de,g,,f,,,


Example Output

cbegdfacgefdba


Hint

 

Author

 xam
#include <iostream>

#include<stdlib.h>

#include<stdio.h>

using namespace std;

char a[55];

int i;

struct mode

{

    struct mode  *l,*r;

    char data;

};

struct mode *creat()

{

    struct mode *root;

    if(a[i++]==',')

        root=NULL;

    else

    {

        root=(struct mode *)malloc(sizeof(struct mode));

        root->data=a[i-1];

        root->l=creat();

        root->r=creat();

    }

    return root;

};

void zhongxu(struct mode *root)

{

    if(root)

    {

        zhongxu(root->l);

        printf("%c",root->data);

        zhongxu(root->r);

    }

}

void houxu(struct mode *root)

{

    if(root)

    {

        houxu(root->l);

        houxu(root->r);

        printf("%c",root->data);

    }

}

int main()

{

    struct mode *root;

    while(~scanf("%s",a))

    {

        i=0;

        root=creat();

        zhongxu(root);

        printf("\n");

        houxu(root);

        printf("\n");

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: