您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树二:遍历二叉树

2015-11-08 11:33 218 查看

数据结构实验之二叉树二:遍历二叉树

Time Limit: 1000MS Memory limit: 65536K

题目描述

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

输入

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

输出

每组输入数据对应输出2行:

第1行输出中序遍历序列;

第2行输出后序遍历序列;

示例输入

abc,,de,g,,f,,,


示例输出

cbegdfacgefdba


提示

来源

xam

示例程序

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char a[100];
int l1;
struct node
{
int data;
struct node *lchild,*rchild;
};
struct node *creat()
{
struct node  *root;
char c;
c=a[l1++];
if(c==',')
return NULL;
else
{
root=(struct node *)malloc(sizeof(struct node));
root->data=c;
root->lchild=creat();
root->rchild=creat();

}
return root;
}
void zhong(struct node *root)
{
if(root)
{
zhong(root->lchild);
printf("%c",root->data);
zhong(root->rchild);
}
}
void hou(struct node *root)
{
if(root)
{
hou(root->lchild);
hou(root->rchild);
printf("%c",root->data);
}
}
int main()
{
int i,j,n,m,k,t;
struct node *root;
while(scanf("%s",a)!=EOF)
{
l1=0;
root=(struct node *)malloc(sizeof(struct node));
root=creat();
zhong(root);
printf("\n");
hou(root);
printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: