您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树二:遍历二叉树

2017-11-12 20:13 169 查看

数据结构实验之二叉树二:遍历二叉树

Time Limit: 1000MS Memory Limit: 65536KB
[align=center]Submit Statistic[/align]

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

每组输入数据对应输出2行:

第1行输出中序遍历序列;

第2行输出后序遍历序列。

 

Example Input

abc,,de,g,,f,,,


Example Output

cbegdfacgefdba


#include<bits/stdc++.h>
using namespace std;
typedef struct node
{
int data;
struct node *left;
struct node *right;
} tree;
int cut;
char s[100];
tree *creat()
{
tree *root;
if(s[cut++]==',')
{
root=NULL;
}
else
{
root=new node;
root->data=s[cut];
root->left=creat();
root->right=creat();
}

return root;
}
void zhongxu(tree *root)
{
if(root)
{
zhongxu(root->left);
cout<<root->data;
zhongxu(root->right);
}

}
void houxu(tree *root)
{
if(root)
{
houxu(root->left);
houxu(root->right);
cout<<root->data;
}
}
int main()
{
while(~scanf("%s",s))
{
cut=0;
tree *root;
root =creat();
zhongxu(root);
cout<<endl;
houxu(root);
cout<<endl;
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: