您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树五:层序遍历

2017-11-07 22:17 176 查看


数据结构实验之二叉树五:层序遍历

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。


Input

 输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。


Output

 输出二叉树的层次遍历序列。


Example Input

2
abd,,eg,,,cf,,,
xnl,,i,,u,,



Example Output

abcdefg
xnuli



Hint

 


Author

 xam

#include <iostream>

#include<stdlib.h>

#include<string.h>

#include<stdio.h>

using namespace std;

char a[55];

int i,count1;

struct mode

{

    struct mode  *l,*r;

    char data;

};

struct mode *creat()

{

    struct mode *root;

    if(a[i++]==',')

        return NULL;

    else

    {

        root=(struct mode *)malloc(sizeof(struct mode));

        root->data=a[i-1];

        root->l=creat();

        root->r=creat();

    }

    return root;

};

void cenxu(struct mode *root)

{

    struct mode *b[100];

    int i=0,j=0;

    b[j++]=root;

    while(i<j)

    {

        if(b[i])

        {

            b[j++]=b[i]->l;

            b[j++]=b[i]->r;

            printf("%c",b[i]->data);

        }

        i++;

    }

}

int deep(struct mode *root)

{

    int d=0;

    if(root)

    {

        int l1=deep(root->l);

        int l2=deep(root->r);

        if(l1>l2)

            d=l1+1;

        else

            d=l2+1;

    }

    return d;

}

int main()

{

    int t;

    struct mode *root;

    scanf("%d",&t);

    while(t--)

    {

        i=0;

        scanf("%s",a);

        root=creat();

        cenxu(root);

        printf("\n");

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: