您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树二:遍历二叉树

2016-10-23 10:36 162 查看

数据结构实验之二叉树二:遍历二叉树

Time Limit: 1000MS Memory Limit: 65536KB
SubmitStatistic

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

每组输入数据对应输出2行:

第1行输出中序遍历序列;

第2行输出后序遍历序列。

 

Example Input

abc,,de,g,,f,,,


Example Output

cbegdfacgefdba


/*创建日期:2016/10/23

代码如下*/

#include <stdio.h>

#include <stdlib.h>

#define lmax 1000000

typedef char Elemtype;

Elemtype str[lmax];      //输入的字符串(定义为全局)

int i;                   //从字符串一一提取

typedef struct tree

{

    Elemtype data;

    struct tree *l;

    struct tree *r

}tree;

tree *creat(tree *t)     //先序建立二叉树

{

    char ch=str[i++];

    if(ch==',')

    {

        t=NULL;

    }

    else

    {

        t=(tree *)malloc(sizeof(tree));

        t->data=ch;

        t->l=creat(t->l);

        t->r=creat(t->r);

    }

    return t;

}

void inorder(tree *t)       //中序遍历

{

    if(t!=NULL)

    {

        inorder(t->l);

        printf("%c",t->data);

        inorder(t->r);

    }

}

void postorder(tree *t)     //后续遍历

{

    if(t!=NULL)

    {

        postorder(t->l);

        postorder(t->r);

        printf("%c",t->data);

    }

}

int main()

{

    tree *t;

    while(~scanf("%s",str))

    {

        i=0;

        t=creat(t);

        inorder(t);

        printf("\n");

        postorder(t);

        printf("\n");

    }

    return 0;

}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: