您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树二:遍历二叉树 (sdut OJ 3341)

2016-08-06 15:52 344 查看

数据结构实验之二叉树二:遍历二叉树


Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

输入

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

输出

每组输入数据对应输出2行:

第1行输出中序遍历序列;

第2行输出后序遍历序列。

示例输入

abc,,de,g,,f,,,


示例输出

cbegdfacgefdba


提示

来源

xam
示例程序

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

struct node
{
char data;
struct node *lchild, *rchild;
}*root;
char st[55];
int cnt;

struct node *creat()
{
struct node *root;
if(st[cnt++] == ',')
root = NULL;
else
{
root = (struct node *)malloc(sizeof(struct node));
root->data = st[cnt-1];
root->lchild = creat();
root->rchild = creat();
}
return root;
}

void zhongxu(struct node *root)
{
if(root)
{
zhongxu(root->lchild);
printf("%c",root->data);
zhongxu(root->rchild);
}
}

void houxu(struct node *root)
{
if(root)
{
houxu(root->lchild);
houxu(root->rchild);
printf("%c",root->data);
}
}

int main()
{
while(~scanf("%s", st))
{
cnt = 0;
root = creat();
zhongxu(root);
printf("\n");
houxu(root);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息