您的位置:首页 > 其它

PAT (Advanced Level) Practise - 1009. Product of Polynomials (25)

2017-11-04 22:46 309 查看


1009. Product of Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000. 

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place. 
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 3 3.6 2 6.0 1 1.6


多项式相乘。

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <map>
using namespace std;
#define LL long long
const int maxn = 2200;
const int inf = 0x3f3f3f3f;
double a[maxn];
double b[maxn];
double ans[maxn];

int main()
{

int n;cin>>n;
for(int i=1;i<=n;i++){
int k;
double c;
cin>>k>>c;
a[k]=c;
}
cin>>n;
for(int i=1;i<=n;i++){
int k;
double c;
cin>>k>>c;
b[k]=c;
}
for(int i=0;i<=1000;i++){
for(int j=0;j<=1000;j++){
ans[i+j]+=a[i]*b[j];
}
}
int p=0;
int num=0;
for(int i=2000;i>=0;i--){
if(ans[i]!=0){
num++;

}
}
printf("%d",num);
for(int i=2000;i>=0;i--){
if(ans[i]!=0){
printf(" %d %.1lf",i,ans[i]);
}
}
printf("\n");

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: