您的位置:首页 > 其它

HDU 1754 I Hate It(线段树区间求最值)

2017-07-31 09:39 204 查看


I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 80489    Accepted Submission(s): 30932


Problem Description

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。

这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。

 

Input

本题目包含多组测试,请处理到文件结束。

在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。

学生ID编号分别从1编到N。

第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。

接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。

当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。

当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。

 

Output

对于每一次询问操作,在一行里面输出最高成绩。

 

Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

 

Sample Output

5
6
5
9

HintHuge input,the C function scanf() will work better than cin

 

Author

linle

 

Source

2007省赛集训队练习赛(6)_linle专场

 

Recommend

lcy

 

Statistic | Submit | Discuss | Note

Link

思路:线段树区间更新求最值

AC代码:

#include <cstdio>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;
#define ll long long
#define FOR( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define MOD 10009
#define bug(x) cout<<#x<<":"<<(x)<<endl;

#define Mid ((l+r)>>1)
#define lson rt<<1,l,Mid
#define rson rt<<1|1,Mid+1,r
const int maxn = 2000000+50;
int sum[maxn<<2],add[maxn<<2];

const int INF=100000;

#define lchild (x << 1)
#define rchild (x << 1 | 1)

int Max[maxn<<2];
//老大坐标
void build(int rt,int l,int r)
{
if(l==r){
scanf("%d",&Max[rt]);
}else{
build(lson);
build(rson);
Max[rt] = max( Max[rt<<1], Max[rt<<1|1]);
}
}
//          老大坐标              光标    修改的值
void update(int rt,int l,int r,int pos,int num)
{
if(l == r && r == pos){
Max[rt] = num;
}else{
if( pos <= Mid)
update(lson,pos,num);
else
update(rson,pos,num);
4000

Max[rt] = max( Max[rt<<1], Max[rt<<1|1]);
}
}
int query(int rt,int l,int r,int L,int R)
{
if(L <= l && r <= R){
return Max[rt];
}else{
int tmp = -1;
if( L <= Mid)
tmp = max(tmp,query(lson,L,R));
if( R > Mid)
tmp = max(tmp,query(rson,L,R));
return tmp;
}
}

int main(){
int n,m;
while(scanf("%d%d",&n,&m)!=EOF){
build(1,1,n);
char str[5];
int l,r;
while(m--){
scanf("%s%d%d",str,&l,&r);
if(str[0]=='Q'){
int res=query(1,1,n,l,r);
printf("%d\n",res);
}
else{
update(1,1,n,l,r);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm hdu