您的位置:首页 > 其它

PAT (Advanced Level) Practise 1082 Read Number in Chinese (25)

2017-07-05 20:13 573 查看


1082. Read Number in Chinese (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output "Fu" first if it is negative. For example, -123456789 is read as "Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu". Note: zero
("ling") must be handled correctly according to the Chinese tradition. For example, 100800 is "yi Shi Wan ling ba Bai".

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.
Sample Input 1:
-123456789

Sample Output 1:
Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu

Sample Input 2:
100800

Sample Output 2:
yi Shi Wan ling ba Bai


题意:输出一个数字的中文读法

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <functional>
#include <climits>

using namespace std;

#define LL long long
const int INF = 0x7FFFFFFF;

string a[10] = { "", "Shi", "Bai", "Qian", "Wan", "Shi", "Bai", "Qian", "Yi" };
string b[10] = { "ling", "yi", "er", "san", "si", "wu", "liu", "qi", "ba", "jiu" };
stack<string>s;

void solve(int x)
{
for (int i = 0; x; i++, x /= 10)
{
if (x % 10)
{
if (i) s.push(a[i]);
s.push(b[x % 10]);
}
else
{
if (i == 4) { if (x % 10000) s.push(a[i]); }
if (s.empty() || s.top() == b[0] || s.top() == a[4]) continue;
s.push(b[0]);
}
}
}

int main()
{
int n;
while (~scanf("%d", &n))
{
solve(abs(n));
if (n < 0) s.push("Fu");
while (!s.empty())
{
cout << s.top();
s.pop();
if (!s.empty()) printf(" ");
}
if (!n) printf("ling");
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: