您的位置:首页 > 大数据 > 人工智能

PAT (Advanced Level) Practise 1090 Highest Price in Supply Chain (25)

2016-03-25 18:07 447 查看


1090. Highest Price in Supply Chain (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root
supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price
given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for
the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the
price will not exceed 1010.
Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:
1.85 2

把树存下来dfs一遍就好了。
#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1e5 + 10;
double p, r, ans;
int n, x, cnt, root;
vector<int> t[maxn];

void dfs(int x, double p)
{
if (!t[x].size())
{
if (p > ans) ans = p, cnt = 1;
else if (p == ans) cnt++;
}
for (int i = 0; i<t[x].size(); i++)
{
dfs(t[x][i], p*(1 + r));
}
}

int main()
{
scanf("%d%lf%lf", &n, &p, &r);  r /= 100;
for (int i = 0; i<n; i++)
{
scanf("%d", &x);
if (x >= 0) t[x].push_back(i);
else root = i;
}
dfs(root, p);
printf("%.2lf %d\n", ans, cnt);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT