您的位置:首页 > 其它

PAT (Advanced Level) Practise 1118 Birds in Forest (25)

2017-06-08 20:03 656 查看


1118. Birds in Forest (25)

时间限制

150 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds,
tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<= 104) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B1 B2 ... BK

where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (<= 104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line "Yes" if the two birds belong to the same tree, or "No" if not.
Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:
2 10
Yes
No


题意:给出n棵树每棵树有哪些鸟,一共问有多少棵树和多少只鸟,然后q次询问,问两只鸟判断是否在同一个树上

解题思路:并查集

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n,q,visit[10050],f[10050],k,x,y;

int Find(int x)
{
return f[x]==x?x:f[x]=Find(f[x]);
}

int main()
{
while(~scanf("%d",&n))
{
for(int i=1;i<=10000;i++) f[i]=i,visit[i]=0;
for(int i=1;i<=n;i++)
{
scanf("%d%d",&k,&x);
visit[x]=1;
int xx=Find(x);
for(int j=2;j<=k;j++)
{
scanf("%d",&y);
visit[y]=1;
int yy=Find(y);
if(xx!=yy) f[yy]=xx;
}
}
int sum1=0,sum2=0;
for(int i=1;i<=10000;i++)
{
if(visit[i]) sum1++;
if(visit[i]&&f[i]==i) sum2++;
}
printf("%d %d\n",sum2,sum1);
scanf("%d",&q);
while(q--)
{
scanf("%d%d",&x,&y);
printf("%s\n",Find(x)==Find(y)?"Yes":"No");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: