您的位置:首页 > 其它

POJ_2139_Six Degrees of Cowvin Bacon【Floyd】

2017-03-14 11:44 351 查看
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

The cows have been making movies lately, so they are ready to play a variant of the famous game

"Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away

 from herself. If two distinct cows have been in a movie together, each is considered to be one

 'degree' away from the other. If a two cows have never worked together but have both worked with

 a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree

  to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree

of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <=

10000) movies and it is guaranteed that some relationship path exists between every pair of cows.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes

 the cows appearing in a single movie. The first integer is the number of cows participating in the

 described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.

Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the

 cows.

Sample Input

4 2

3 1 2 3        

2 3 4

Sample Output

100          

题意:如果两头牛在同一部电影中出现过,那么这两头牛的度就为1, 如果这两头牛a,b没有在同一部电影中出现过,但a,b分别与c在同一部电影中出现过,那么a,b的度为2。以此类推,a与b之间有n头媒介牛,那么a,b的度为n+1。 给出m部电影,每一部给出牛的个数,和牛的编号。问那一头到其他每头牛的度数平均值最小,输出最小平均值乘100。

题解:到所有牛的度数的平均值最小,也就是到所有牛的度数总和最小。那么就是找这头牛到其他每头牛的最小度,也就是最短路径,相加再除以(n-1)就是最小平均值。对于如何确定这头牛,我们可以枚举,最后记录最下平均值即可。

#include <stdio.h>
#include <string.h>
#define inf 0x3f3f3f3f
int dist[305][305];
int g[305];
int n,m;
int Floyd()
{
int i,j,k;
for(k=1;k<=n;k++)
{
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
if(dist[i][j] > dist[i][k] + dist[k][j])
{
dist[i][j] = dist[i][k] + dist[k][j];
}
}
}
}

}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
int t;
int i,j,k;
memset(dist,inf,sizeof(dist));
for(i=1;i<=m;i++)
{
scanf("%d",&t);
for(j=1;j<=t;j++)
{
scanf("%d",&g[j]);
}
for(j=1;j<t;j++)
{
for(k=j+1;k<=t;k++)
{
dist[g[j]][g[k]] = dist[g[k]][g[j]] = 1;
}
}
}
Floyd();
int min =  inf;
for(i=1;i<=n;i++)
{
int res = 0;
for(j=1;j<=n;j++)
{
if(i!=j)
{
res += dist[i][j];
}
}
if(res<min)
{
min = res;
}
}
printf("%d\n",min*100/(n-1));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: