您的位置:首页 > 其它

Six Degrees of Cowvin Bacon POJ - 2139 (floyd求最短路)

2017-12-06 19:40 597 查看

Six Degrees of Cowvin Bacon

POJ - 2139



The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together
but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship
path exists between every pair of cows.

Input
* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers
tell which cows were.

Output
* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.

Sample Input
4 2
3 1 2 3
2 3 4

Sample Output
100

Hint
[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .]

题意:两头牛在一个电影中出现,那么他们之间算作1(连通),如果两头牛没有在一个电影中过,但是有一头牛和这两头牛分别在同一个电影中过,则这两头牛之间也算作1,
这样一想就是一个图,给定a b说明ab直接相连给定ab bc  则ac也间接相连,求一个牛到其他所有的牛的距离最小(每个距离为1),就是求最短路,可以用弗洛伊德算法,然后枚举每个点,最终得到结果
code:
#include <iostream>
#include <cstring>
using namespace std;
#define INF 0x3f3f3f3f
int G[303][303];
int n,m;
int x[303];
int main(){
memset(G,INF,sizeof(G));
cin >> n >> m;
int i,j,k;
for(i = 0; i < n; i++)
G[i][i] = 0;//必须有这句
while(m--){
int num;
cin >> num;
for(i = 0; i < num; i++){
cin >> x[i];
--x[i];
}
for(i = 0; i < num; i++){
for(j = i+1; j < num; j++){
G[x[i]][x[j]] = 1;
G[x[j]][x[i]] = 1;
}
}
}
//folyd
for(k = 0; k < n; k++){
for(i = 0; i < n; i++){
for(j = 0; j < n; j++){
G[i][j] = min(G[i][j],G[i][k]+G[k][j]);
}
}
}
int sum,ans = INF;
for(i = 0; i < n; i++){
sum = 0;
for(j = 0; j < n; j++){
sum += G[i][j];
}
ans = min(ans,sum);
}
cout << 100*ans/(n-1) << endl;//n-1 except himself
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: