您的位置:首页 > 其它

POJ_1511_Invitation Cards【双向最短路】

2017-03-21 21:45 267 查看
/*

Invitation Cards

Time Limit: 8000MS        Memory Limit: 262144K

Total Submissions: 26826        Accepted: 8896

Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact.

 They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary

  information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student

  volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling

  by bus. A special course was taken where students learned how to influence people and what is the difference between

  influencing and robbery.

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating

stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they

 wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is

  given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey

   starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a

   thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers

. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer

 program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case

begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q

the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers

- the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the

sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its

volunteers.

Sample Input

2

2 2

1 2 13

2 1 33

4 6

1 2 10

2 1 60

1 3 20

3 4 10

2 4 5

4 1 50

Sample Output

46

210

最短路

题意:  有向图 , n个点(1到n标号)m条边,求出点1到所有点的最短路之和 + 所有点到点1的最短路之和

*/

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
const int Max = 1000000+10;
int head[Max];
int head1[Max];
bool vis[Max];
int dist[Max];
struct Node
{
int v;
int w;
int next;
}edge[Max],edge1[Max];
int num,n,m,num1;
void init()
{
memset(dist,0x3f,sizeof(dist));
memset(vis,false,sizeof(vis));
}
void add_edge(int u,int v,int w)
{
edge[num].v = v;
edge[num].w = w;
edge[num].next = head[u];
head[u] = num ++ ;
}

void add_edge1(int u,int v,int w)
{
edge1[num1].v = v;
edge1[num1].w = w;
edge1[num1].next = head1[u];
head1[u] = num1 ++ ;
}
void SPFA(int u)
{
init();
int v,i,w;
queue<int >Q;
dist[u] = 0;
vis[u] = true;
Q.push(u);
while(!Q.empty())
{
u = Q.front();
Q.pop();
vis[u] = false;
for(i=head[u];i!=-1;i=edge[i].next)
{
v = edge[i].v;
w = edge[i].w;
if(dist[v] > dist[u] + w)
{
dist[v] = dist[u] + w;
if(!vis[v])
{
vis[v] = true;
Q.push(v);
}
}
}
}
}

void SPFA1(int u)
{
init();
int v,i,w;
queue<int >Q1;
dist[u] = 0;
vis[u] = true;
Q1.push(u);
while(!Q1.empty())
{
u = Q1.front();
Q1.pop();
vis[u] = false;
for(i=head1[u];i!=-1;i=edge1[i].next)
{
v = edge1[i].v;
w = edge1[i].w;
if(dist[v] > dist[u] + w)
{
dist[v] = dist[u] + w;
if(!vis[v])
{
vis[v] = true;
Q1.push(v);
}
}
}
}
}
int main()
{
int T,i,j;
scanf("%d",&T);
while(T--)
{
num = 0,num1 = 0;
memset(head,-1,sizeof(head));
memset(head1,-1,sizeof(head1));
int a,b,c;

scanf("%d%d",&n,&m);
int f = 0;
for(i=1;i<=m;i++)
{
scanf("%d%d%d",&a,&b,&c);
add_edge(a,b,c);
add_edge1(b,a,c);
}
SPFA(1);
__int64 sum = 0; //数据太大,用int定义,果断wa
for(i=1;i<=n;i++)
{
sum += dist[i];
}
SPFA1(1);
for(i=1;i<=n;i++)
{
sum += dist[i];
}
printf("%lld\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: