您的位置:首页 > 理论基础 > 数据结构算法

sdutacm-数据结构实验之链表三:链表的逆置

2017-03-03 17:03 369 查看
数据结构实验之链表三:链表的逆置

TimeLimit: 1000MS Memory Limit: 65536KB

SubmitStatistic

ProblemDescription

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

Input

输入多个整数,以-1作为结束标志。

Output

输出逆置后的单链表数据。

ExampleInput

1256 4 6 55 15 33 62 -1

ExampleOutput

6233 15 55 6 4 56 12

Hint

不得使用数组。

Author

  C
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
int a;
struct node *next;

};
struct node*creat()
{
struct node *head,*p,*tail;
head = (struct node*)malloc(sizeof(struct node));
head->next =NULL;

for(int i=1;;i++)
{
p = (struct node*)malloc(sizeof(struct node));

scanf("%d",&p->a); if(p->a==-1)break;
p -> next= head->next;
head->next = p;

}
return head;

}
void show(struct node *head)
{
struct node *p;
p = head->next;
while(p!=NULL)
{
if(p->next!=NULL)
{
printf("%d ",p->a);
}
else
{
printf("%d\n",p->a);
}
p = p->next;

}

}
int main()
{

int n;

struct node *head;
head= creat();

show(head);
return 0;

}

/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 0ms
Take Memory: 116KB
Submit time: 2017-01-12 15:32:45
****************************************************/
C2
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct node
{
int data;
struct node *next;

};
struct node*creat()
{
struct node *tail,*p,*head;
head = (struct node*)malloc(sizeof(struct node));
head->next=NULL;
tail = head;
while(1)
{

p = (struct node*)malloc(sizeof(struct node));

scanf("%d",&p->data);
if(p->data==-1)break;
p ->next = NULL;

tail->next = p;
tail = p;

}
return (head);

}
struct node*ncreat(int n)

{ struct node *head,*p;
head = (struct node*)malloc(sizeof(struct node));
head->next = NULL;

for(int i=1;i<=n;i++)
{
p = (struct node*)malloc(sizeof(struct node));
scanf("%d",&p->data);

p->next = head->next;
head->next = p;

}
return (head);

}
void show(struct node*head)
{

struct node *p;
p =head->next;
while(p)
{

if(p->next!=NULL)
{
printf("%d ",p->data);

}
else
{
printf("%d\n",p->data);
}
p = p->next;

}

}
int del(struct node *head,int n)
{

struct node *p,*q,*t;
p = head->next;
while(p)
{
q = p;
t = q->next;
while(t)
{

if(p->data==t->data)
{
q->next = t->next;
free(t);
t = q->next;
n--;

}
else
{
q = t;
t = q->next;
}
}
p = p->next;

}
return n;

}
void nizhi(struct node*head)
{

struct node *p,*q;
p = head->next;
head ->next = NULL;
q = p->next;
while(p)
{
p->next = head->next;
head->next = p;
p = q;
if(q)
{
q = q->next;
}

}

}
int main()
{

struct node *head;
head = (struct node*)ma
4000
lloc(sizeof(struct node));

int n;

head=creat();

nizhi(head);
show(head);

return 0;
}

/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 0ms
Take Memory: 104KB
Submit time: 2017-01-12 20:54:25
****************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm sdut c语言 算法