您的位置:首页 > 理论基础 > 数据结构算法

sdutacm-数据结构实验之链表七:单链表中重复元素的删除

2017-03-04 22:09 806 查看
数据结构实验之链表七:单链表中重复元素的删除
TimeLimit: 1000MS Memory Limit: 65536KB

SubmitStatistic
ProblemDescription
按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。
Input
第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n
个整数,保证在 int
范围内。
Output
第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。
ExampleInput

10
21 30 14 55 32 63 11 30 55 30

ExampleOutput

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

Hint
Author
不得使用数组!
G
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct node
{
int data;
struct node *next;

};
struct node*creat()
{
struct node *tail,*p,*head;
head = (struct node*)malloc(sizeof(struct node));
head->next=NULL;
tail = head;
while(1)
{

p = (struct node*)malloc(sizeof(struct node));

scanf("%d",&p->data);
if(p->data==-1)break;
p ->next = NULL;

tail->next = p;
tail = p;

}
return (head);

}
struct node*ncreat(int n)

{ struct node *head,*p;
head = (struct node*)malloc(sizeof(struct node));
head->next = NULL;

for(int i=1;i<=n;i++)
{
p = (struct node*)malloc(sizeof(struct node));
scanf("%d",&p->data);

p->next = head->next;
head->next = p;

}
return (head);

}
void show(struct node*head)
{

struct node *p;
p =head->next;
while(p)
{

if(p->next!=NULL)
{
printf("%d ",p->data);

}
else
{
printf("%d\n",p->data);
}
p = p->next;

}

}
int del(struct node *head,int n)
{

struct node *p,*q,*t;
p = head->next;
while(p)
{
q = p;
t = q->next;
while(t)
{

if(p->data==t->data)
{
q->next = t->next;
free(t);
t = q->next;
n--;

}
else
{
q = t;
t = q->next;
}
}
p = p->next;

}
return n;

}
void nizhi(struct node*head)
{

struct node *p,*q;
p = head->next;
head ->next = NULL;
q = p->next;
while(p)
{
p->next = head->next;
head->next = p;
p = q;
if(q)
{
q = q->next;
}

}

}
int main()
{

struct node *head;
head = (struct node*)malloc(sizeof(struct node));

int n;
scanf("%d",&n);

head=ncreat(n);
printf("%d\n",n);
show(head);
int m = del(head,n);
printf("%d\n",m);

show(head);

return 0;
}

/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 0ms
Take Memory: 108KB
Submit time: 2017-01-12 20:55:54
****************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm sdut c语言 算法
相关文章推荐