您的位置:首页 > 理论基础 > 数据结构算法

OJ 数据结构实验之链表三:链表的逆置

2015-04-16 00:13 537 查看


数据结构实验之链表三:链表的逆置



Time Limit: 1000MS Memory limit: 65536K


题目描述

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。


输入

输入多个整数,以-1作为结束标志。


输出

输出逆置后的单链表数据。


示例输入

12 56 4 6 55 15 33 62 -1



示例输出

62 33 15 55 6 4 56 12


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
int data;
struct node *next;
};
struct node *head,*p,*q,*p1,*q1;
int main()
{
int x;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
while(~scanf("%d",&x))
{
if(x==-1)
break;
else
{
p=(struct node *)malloc(sizeof(struct node));
p->data=x;
p->next=head->next;
head->next=p;
}
}
q=head->next;
while(q)
{
if(q->next!=NULL)
printf("%d ",q->data);
else
printf("%d\n",q->data);
q=q->next;
}
return 0;
}



数据结构实验之链表三:链表的逆置



Time Limit: 1000MS Memory limit: 65536K


题目描述

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。


输入

输入多个整数,以-1作为结束标志。


输出

输出逆置后的单链表数据。


示例输入

12 56 4 6 55 15 33 62 -1



示例输出

62 33 15 55 6 4 56 12
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: