您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树二:遍历二叉树

2017-02-15 11:01 155 查看
数据结构实验之二叉树二:遍历二叉树

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

每组输入数据对应输出2行:

第1行输出中序遍历序列;

第2行输出后序遍历序列。

Example Input

abc,,de,g,,f,,,

Example Output

cbegdfa

cgefdba

Hint

Author

xam

因为不懂,看了好久,貌似懂点了

#include<stdio.h>
#include<stdlib.h>
struct node
{
char data;
struct node *l, *r;
}tree;
char a[51];
int top;
struct node *creat()
{
struct node *root;
top++;
if(a[top] == ',')
root = NULL;
else
{
root = (struct node*) malloc(sizeof(struct node));
root->data = a[top];
root->l = creat();
root->r = creat();
}
return root;
};
void zhongxu(struct node *root)
{
if(root)
{
zhongxu(root -> l);
printf("%c", root -> data);
zhongxu(root -> r);
}
}
void houxu(struct node *root)
{
if(root)
{
houxu(root -> l);
houxu(root -> r);
printf("%c", root -> data);
}
}
int main()
{
while(~scanf("%s", a))
{
top = -1;
struct node *root;
root = creat();
zhongxu(root);
printf("\n");
houxu(root);
printf("\n");
}
return 0;
}


977c
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: