您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树二:遍历二叉树

2016-10-29 20:46 162 查看

数据结构实验之二叉树二:遍历二叉树

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

每组输入数据对应输出2行:

第1行输出中序遍历序列;

第2行输出后序遍历序列。

 

Example Input

abc,,de,g,,f,,,


Example Output

cbegdfacgefdba
#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
struct node
{
char data;
struct node *l,*r;
};
struct node *root;
char a[1010];
int count;
struct node *creat()//按照先序序列创建二叉树
{
struct node *root;
if(a[count++]==',')
root=NULL;
else
{
root=(struct node *)malloc(sizeof(struct node ));
root->data=a[count-1];
root->l=creat();
root->r=creat();
}
return root;
};
void inorder(struct node *root)//中序遍历
{
if(root)
{
inorder(root->l);
cout<<root->data;
inorder(root->r);
}
}
void postorder(struct node *root)//中序遍历
{
if(root)
{
postorder(root->l);
postorder(root->r);
cout<<root->data;
}
}
int main()
{
int t;
while(~scanf("%s",a))
{
count=0;
root=creat();
inorder(root);
cout<<endl;
postorder(root);
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: