您的位置:首页 > 其它

poj1789——Truck History(最小生成树+prim)

2016-09-01 10:56 393 查看
Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company’s history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan – i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.

Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text “The highest possible quality is 1/Q.”, where 1/Q is the quality of the best derivation plan.

Sample Input

4

aaaaaaa

baaaaaa

abaaaaa

aabaaaa

0

Sample Output

The highest possible quality is 1/3.

题目很难读,但读懂了就很容易。大意是给出n个代码,每个代码可能由另一个代码衍生过来,衍生的花费是,1/有不同的字母的位置的个数,要求求出最大的这个,由于是倒数,所以反过来求分母的最小值就行。样例中,第一个代码衍生出后三个代码的花费最小,都为1,所以最大花费是1/3.

然后就可以转化为最小生成树来求

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 2005
#define Mod 10001
using namespace std;
int n,vis[MAXN],map[MAXN][MAXN],dis[MAXN];
string s[MAXN];
int getdis(int a,int b)
{
int ans=0;
for(int i=0;i<7;++i)
if(s[a][i]!=s[b][i])
ans++;
return ans;
}
int prim()
{
int i,j,pos,min,ans=0;
memset(vis,0,sizeof(vis));
vis[1]=1,pos=1;
for(i=1; i<=n; ++i)
if(i!=pos)
dis[i]=map[pos][i];
for(i=1; i<n; ++i)
{
min=INF;
for(j=1; j<=n; ++j)
if(!vis[j]&&dis[j]<min)
{
min=dis[j];
pos=j;
}
ans+=min;
vis[pos]=1;
for(j=1; j<=n; ++j)
if(!vis[j]&&dis[j]>map[pos][j])
dis[j]=map[pos][j];
}
return ans;
}
int main()
{
while(~scanf("%d",&n)&&n)
{
for(int i=1;i<=n;++i)
cin>>s[i];
for(int i=1;i<=n;++i)
for(int j=1;j<=n;++j)
map[i][j]=getdis(i,j);
printf("The highest possible quality is 1/%d.\n",prim());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: