您的位置:首页 > 其它

POJ1789,Truck History,最小生成树,Prim

2012-11-25 19:05 459 查看
Truck History

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase
letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types
were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different
letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/Σ(to,td)d(to,td)
where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.

Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that
the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.
Sample Input
4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output
The highest possible quality is 1/3.


分析:

题意大概是这样的:用一个7位的string代表一个编号,两个编号之间的distance代表这两个编号之间不同字母的个数。一个编号只能由另一个编号“衍生”出来,代价是这两个编号之间相应的distance,现在要找出一个“衍生”方案,使得总代价最小,也就是distance之和最小。

每一个编号看成树的一个节点...用Prim算法很容易求出最小生成树的权值和.

code:

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
#define MAX 2000
#define INF 10
using namespace std;
char s[MAX+10][8];
int N,dis[MAX+10][MAX+10];
int weight(int i,int j)
{
int w=0;
for(int k=0;k<7;k++)
if(s[i][k]!=s[j][k])
w++;
return w;
}
int prim()
{
int s=1,num=1,sum_w=0,min_w,flag,low_dis[MAX+10];
bool uni[MAX+10];
memset(uni,false,sizeof(uni));
memset(low_dis,INF,sizeof(low_dis));
uni[s]=true;
while(1)
{
if(num==N) break;
min_w=INF;
for(int i=2;i<=N;i++)
{
if(!uni[i]&&dis[s][i]<low_dis[i])
low_dis[i]=dis[s][i];
if(!uni[i]&&low_dis[i]<min_w)
{
min_w=low_dis[i];
flag=i;
}
}
uni[flag]=true;
s=flag;
num++;
sum_w+=min_w;
}
return sum_w;
}
int main()
{
//freopen("input.txt","r",stdin);
while(scanf("%d",&N),N)
{
for(int i=1;i<=N;i++)
cin>>s[i];
for(int i=1;i<=N;i++)
for(int j=1;j<=N;j++)
dis[i][j]=dis[j][i]=weight(i,j);
printf("The highest possible quality is 1/%d.\n",prim());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: