您的位置:首页 > 其它

POJ1789 Truck History(Prim最小生成树)

2014-03-26 23:40 447 查看
题目链接:http://poj.org/problem?id=1789

Truck History

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16492 Accepted: 6344
Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase
letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types
were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different
letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 

Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that
the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.
Sample Input
4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output
The highest possible quality is 1/3.


题意:有n个长度为7的字符串,定义它们之间的距离为不同字符的个数(字符串同一位置进行比较,有不同则距离加1)。除了第一个以外,每一个字符串都继承自另一个,

求一种继承方案使得总距离最小。

将每个字符串视作一个点,问题就转化成了求图的最小生成树。

由于每两个点之间都有距离,所以用Prim算法较为合适。(复杂度O(n*n))

注意格式以及最后的“.”

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;

const int inf=0x3f3f3f3f;
int g[2005][2005],dis[2005];
char s[2005][10];
int n;

int prim(int n,int m)//Prim求最小生成树
{
memset(dis,0x3f,sizeof(dis));
int now,min_code,min_edge,ans;
now=0;ans=0;
for (int i=0;i<n-1;i++)
{
dis[now]=-1;
min_edge=inf;
for (int j=0;j<n;j++)
{
if (j!=now&&dis[j]>=0)
{
dis[j]=min(dis[j],g[now][j]);
if (dis[j]<min_edge)
{
min_edge=dis[j];
min_code=j;
}
}
}
ans+=min_edge;
now=min_code;
}
return ans;
}

int main()
{
while (scanf("%d",&n)!=EOF&&n!=0)
{
memset(g,0,sizeof(g));
for (int i=0;i<n;i++)
{
scanf("%s",s[i]);
}
for (int i=0;i<n-1;i++)//穷举求出两两之间距离
{
for (int j=i+1;j<n;j++)
{
for (int k=0;k<7;k++)
{
if (s[i][k]!=s[j][k]) ++g[i][j];
}
g[j][i]=g[i][j];
}
}
printf("The highest possible quality is 1/%d.\n",prim(n,n));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj 最小生成树