您的位置:首页 > 其它

hdu 1002 大数相加

2016-08-14 10:54 375 查看
原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1002

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2

1 2

112233445566778899 998877665544332211

Sample Output

Case 1:

1 + 2 = 3

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

用字符串实现:

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
string add(string s1,string s2);
int main()
{
int n,t=1;
string s1,s2,sum;
cin>>n;
while(n--)
{
cin>>s1>>s2;
sum = add(s1,s2);
cout << "Case " << t << ":" << endl ;
cout << s1 << " + " << s2 <<  " = " << sum << endl;
t++;
if(n>0)cout<<endl;
}
return 0;
}
string add(string s1,string s2)
{
if (s1 == "0" && s2 == "0") return "0"; //0的处理
if (s1 == "0") return s2;//0的处理
if (s2 == "0") return s1;//0的处理
string max = s1,min = s2;
if (s1.length()<s2.length())
{
max = s2;
min = s1;
}
int a = max.length()-1,b = min.length()-1;
for(int i=b;i>=0;i--)
{max[a--] += min[i] -'0';}
for(int i = max.length()-1;i>0;i--)
{
if(max[i]>'9')
{
max[i] -= 10;
max[i-1]++;
}

}
if(max[0]>'9')//位数相同,最高位大于9
{max[0] -=10;
max = '1'+max;}
return max;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: