您的位置:首页 > 其它

hdu 1002 A + B Problem II(大数相加)

2017-10-30 19:27 295 查看


A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 378548    Accepted Submission(s): 73713


Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using
32-bit integer. You may assume the length of each integer will not exceed 1000.

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line
between two test cases.

 

Sample Input

2
1 2
112233445566778899 998877665544332211

 

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

 

Author

Ignatius.L

 

Recommend

We have carefully selected several similar problems for you:  1004 1008 1005 1089 1093 

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;

int main()
{
char a[1010],b[1010];
int na[1010],nb[1010];
int sum[2020];
int T,n1,n2;
scanf("%d",&T);
for(int i=1;i<=T;i++)
{
memset(na,0,sizeof(na));
memset(nb,0,sizeof(nb));
memset(sum,0,sizeof(sum));
scanf("%s %s",a,b);
n1=strlen(a);
n2=strlen(b);
int lenx=n1>n2?n1:n2;
for(int j=0;j<n1;j++)
na[n1-1-j]=a[j]-'0';
for(int j=0;j<n2;j++)
nb[n2-1-j]=b[j]-'0';
int pre=0;
for(int j=0;j<lenx;j++)
{
sum[j]=na[j]+nb[j]+pre/10;
pre=sum[j];
}
while(pre>9)
{
sum[lenx]=pre/10%10;
lenx++;
pre/=10;
}
printf("Case %d:\n",i);
printf("%s + %s = ",a,b);
for(int j=lenx-1;j>=0;j--)
{
printf("%d",sum[j]%10);
}
printf("\n");
if(i<T)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: