您的位置:首页 > 其它

HDU-1002-大数相加

2016-08-11 10:17 323 查看

A + B Problem II

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 317183    Accepted Submission(s): 61609
[/b]

[align=center]Problem Description[/align]
[align=center]I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
[/align]
[align=center] [/align]
[align=center]
[/align]
[align=center]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that
means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

[align=center] [/align]
[align=center]
[/align]
[align=center]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some
spaces int the equation. Output a blank line between two test cases.

[align=center] [/align]
[align=center]
[/align]
[align=center]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211

[align=center] [/align]
[align=center]
[/align]
[align=center]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

[align=center] [/align]
[align=center]
[/align]
[align=center]Author[/align]
[align=center]Ignatius.L[/align]
[align=center] [/align]

#include<stdio.h>

#include<string.h>

#define MAX 1001

void largenumber(char a[],char b[],char d[])

{

    int i,j;

    int t=0;//补位

    int  A[MAX]={0};

    int  B[MAX]={0};

    char c[MAX];

int a_length,b_length;

int max_size;

a_length=strlen(a);

b_length=strlen(b);

max_size=(a_length>b_length)?a_length:b_length;//求最大的长度

for(i=0;i<max_size;i++)//倒置字符串用int保存,多余位置为0

{

(a_length>i)?A[i]=a[a_length-i-1]-'0':A[i]=0;

(b_length>i)?B[i]=b[b_length-i-1]-'0':B[i]=0;

}

for(i=0;i<max_size;i++)

{

if((A[i]+B[i]+t)>=10)//加了补位大于10

{

c[i]=(A[i]+B[i]+t)%10+'0';

t=1;

}

else

{

c[i]=(A[i]+B[i]+t)+'0';

t=0;

}

}

if(t==1){c[i]=t+'0';c[i+1]='\0';}//对于最后位补位的判断

else

{

c[i]='\0';

}

for(i=0;i<strlen(c);i++)//倒置

   d[i]=c[strlen(c)-i-1];

d[i]='\0';

}

int main()

{

    char a[MAX],b[MAX],c[MAX];

    int n;

    int count=0;

    scanf("%d",&n);

    while(n--)

   
4000
{

        count++;

    scanf("%s",a);

    scanf("%s",b);

largenumber(a,b,c);

printf("Case %d:\n",count);

printf("%s + %s = %s",a,b,c);

if(n!=0) printf("\n\n");

else  printf("\n");

    }

   

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: