您的位置:首页 > 其它

hdu1002 a+bII 大数相加

2014-06-02 03:29 429 查看
表示无力吐槽!!又错了好几次 发表以明志!!!

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.



Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.



Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.



Sample Input
2
1 2
112233445566778899 998877665544332211




Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110



#include<stdio.h>
#include<string.h>
#define MAXN 1005
char a[MAXN], b[MAXN];
int c[MAXN];
int main()
{
	int t, i, j, k, v = 1;
	scanf( "%d", &t );
	while( t -- )
	{
		memset( c, 0, sizeof(c) );
		scanf( "%s %s", a, b );
		int la = strlen(a), lb = strlen(b);
		i = la-1, j = lb-1;
		k = 0;
		while( i>=0&&j>=0 )
		{
			c[++k] += a[i--]-'0'+b[j--]-'0';
			if( c[k] > 9 )
			{
				c[k]-=10;
				++c[k+1];
			}
		}
		while(i>=0)
		{
			c[++k] += a[i--]-'0';
			if( c[k] > 9 )
			{
				c[k]-=10;
				++c[k+1];
			}
		}
		while(j>=0)
		{
			c[++k] += b[j--]-'0';
			if( c[k] > 9 )
			{
				c[k]-=10;
				++c[k+1];
			}
		}
		printf( "Case %d:\n", v++ );
		printf( "%s + %s = ", a, b );
		for( i = MAXN; i > 0; i -- )
		if( c[i] ) break;
		for( ; i >0; i -- )
		printf( "%d", c[i] );
		printf( "\n" );
		if(t!=0)
		printf( "\n" );
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: