您的位置:首页 > 其它

hdu 1002 大数相加

2016-08-12 11:03 435 查看
Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using
32-bit integer. You may assume the length of each integer will not exceed 1000.

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line
between two test cases.

 

Sample Input

2
1 2
112233445566778899 998877665544332211

 

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Java代码不能带有package语句,主类必须是Main

import java.util.Scanner;
import java.math.*;
public class Main {
public static void main(String args []){
Scanner input=new Scanner(System.in);
int T;
T=input.nextInt();
for(int i=1;i<=T;i++){
BigInteger a,b;
a=input.nextBigInteger();
b=input.nextBigInteger();
if(i!=1)
System.out.println();
System.out.println("Case "+i+":");
System.out.println(a+" + "+b+" = "+a.add(b));
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: