您的位置:首页 > 其它

数学向量推导______Acperience( hdu 5734 2016多校 )

2016-08-13 21:52 411 查看
Problem Description

Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art
results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus),
augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems
need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector W=(w1,w2,...,wn).
Professor Zhang would like to find a binary vector B=(b1,b2,...,bn) (bi∈{+1,−1})and
a scaling factor α≥0 in
such a manner that ∥W−αB∥2 is
minimum.

Note that ∥⋅∥ denotes
the Euclidean norm (i.e. ∥X∥=x21+⋯+x2n−−−−−−−−−−−√,
where X=(x1,x2,...,xn)).

 

Input

There are multiple test cases. The first line of input contains an integer T,
indicating the number of test cases. For each test case:

The first line contains an integers n (1≤n≤100000) --
the length of the vector. The next line contains n integers: w1,w2,...,wn (−10000≤wi≤10000).

 

Output

For each test case, output the minimum value of ∥W−αB∥2 as
an irreducible fraction "p/q"
where p, q are
integers, q>0.

 

Sample Input

3
4
1 2 3 4
4
2 2 2 2
5
5 6 2 3 4

 

Sample Output

5/1
0/1
10/1

 

题意:

给出向量w,α>0,b向量满足每个维度坐标不是1就是-1.现在求向量w-αb的模的平方的最小值。

分析:

画图可知。最小值一定是w-αb这个向量垂直于αb向量的时候。所以化简公式可以得到

最小值等于 (len*n-sum*sum)/n  ,   n 表示维度, len 表示 w 向量模的平方, sum 表示w坐标之和。

代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<string>
#include<cstdlib>
#include<ctime>

#include<vector>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;

long long a[100010];

int main()
{

int t ;
cin >> t;
while(t--)
{
int n;
cin >> n;
for(int i = 0 ; i < n ; i ++)
scanf("%lld",&a[i]);
long long m2 = 0;
long long sum = 0;
for(int i = 0 ; i < n ; i ++)
{
m2 += a[i]*a[i];
sum += abs(a[i]);
}
long long fz = m2 * n - sum*sum;
long long fm = n;
long long gcd = __gcd(fz,fm);
printf("%lld/%lld\n",fz/gcd,fm/gcd);
}
return 0;
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 5734 2016 多校