您的位置:首页 > 其它

hdu 3117 Fibonacci Numbers(数学推导+矩阵连乘)

2015-08-13 19:33 330 查看
题目:http://acm.hdu.edu.cn/showproblem.php?pid=3117

Description

The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.



What is the numerical value of the nth Fibonacci number?


Input

For each test case, a line will contain an integer i between 0 and 10 8 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than
8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“...”).

There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).



Sample Input

0
1
2
3
4
5
35
36
37
38
39
40
64
65




Sample Output

0
1
1
2
3
5
9227465
14930352
24157817
39088169
63245986
1023...4155
1061...7723
1716...7565




对于位数大于8的情况:前四位和前一篇博客的做法一样,巧用对数。后四位则和取模运算相关。用矩阵连乘取模运算计算出后四位。另外注意有可能后四位计算取模后得到的位数小于4,所以在这种情况下要在前面加上0补足4位。

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
const int mod=1e4;
int f[45];
struct matrix{
    int m[2][2];
};
matrix A=
{
    1,1,
    1,0
};
matrix I={
    1,0,
    0,1
};
matrix multi(matrix a,matrix b){
    matrix c;
    for(int i=0;i<2;i++){
        for(int j=0;j<2;j++){
            c.m[i][j]=0;
            for(int k=0;k<2;k++) c.m[i][j]+=a.m[i][k]*b.m[k][j]%mod;
            c.m[i][j]%=mod;
        }
    }
    return c;
}
matrix power(matrix a,int k){
    matrix ans=I,p=a;
    while(k){
        if(k&1)ans=multi(ans,p);
        k=k>>1;
        p=multi(p,p);
    }
    return ans;
}
int main()
{
    //freopen("cin.txt","r",stdin);
    f[1]=1;
    for(int i=2;i<40;i++){  //40刚好超过8位
        f[i]=f[i-1]+f[i-2];
    }
    double q1=log10(1/sqrt(5)),q2=log10((1+sqrt(5))/2);
    int n;
    while(cin>>n){
        if(n<40){
            printf("%d\n",f
);
            continue;
        }
         double t=(q1+n*q2);
         int ans1=(int)(pow(10,t-int(t))*1000),ans2=power(A,n-1).m[0][0];
         /*int len=log10(ans2)+1;// why is it wrong? Output Limit Exceeded
         if(len<4){
             printf("%d...",ans1);
             for(int k=0;k<4-len;k++)printf("0");
             printf("%d\n",ans2);
         }*/
        printf("%d...%0.4d\n",ans1,ans2);  
    }
    return 0;
}
"%0.4d"就和"%04d"效果一样,表示输出至少4位,不足则在左边补0.
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: