您的位置:首页 > 其它

HDU-1018-Big Number( 这段数学推导我给满分! && 然而并不想用斯特林公式! )

2016-02-14 12:06 597 查看


Big Number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 32770 Accepted Submission(s): 15387



Problem Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of
the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20


Sample Output

7
19


Source

Asia 2002, Dhaka (Bengal)

Recommend

JGShining | We have carefully selected several similar problems for you: 1016 1071 1019 1061 1060

下面这段数学推理,是大牛xiaonian分析出来。不得不承认,他的分析很不错。

Posted by xiaonian at 2013-05-04 14:07:10 on Problem 1018

/****************************************************
这题要求n的阶乘的位数,如果n较大时,n的阶乘必将是一个
很大的数,题中说1<=n<10000000,当n=10000000时可以说n
的阶乘将是一个非常巨大的数字,对于处理大数的问题,我
们一般用字符串,这题当n取最大值时,就是一千万个数字相
乘的积,太大了,就算保存在字符串中都有一点困难,而且
一千万个数字相乘是会涉及到大数的乘法,大数的乘法是比较
耗时的,就算计算出结果一般也会超时。这让我们不得不抛弃
这种直接的方法。

再想一下,这题是要求n的阶乘的位数,而n的阶乘是n个数的
乘积,那么要是我们能把这个问题分解就好了。

在这之前,我们必须要知道一个知识,任意一个正整数a的位数
等于(int)log10(a) + 1;为什么呢?下面给大家推导一下:

对于任意一个给定的正整数a,
假设10^(x-1)<=a<10^x,那么显然a的位数为x位,
又因为
log10(10^(x-1))<=log10(a)<(log10(10^x))
即x-1<=log10(a)<x
则(int)log10(a)=x-1,
即(int)log10(a)+1=x
即a的位数是(int)log10(a)+1

我们知道了一个正整数a的位数等于(int)log10(a) + 1,
现在来求n的阶乘的位数:
假设A=n!=1*2*3*......*n,那么我们要求的就是
(int)log10(A)+1,而:
log10(A)=log10(1*2*3*......n)  (根据log10(a*b) = log10(a) + log10(b)有)
=log10(1)+log10(2)+log10(3)+......+log10(n)
现在我们终于找到方法,问题解决了,我们将求n的阶乘的位
数分解成了求n个数对10取对数的和,并且对于其中任意一个数,
都在正常的数字范围之类。

总结一下:n的阶乘的位数等于
(int)(log10(1)+log10(2)+log10(3)+......+log10(n)) + 1

根据这个思路我们很容易写出程序
****************************************************/


#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
int T,n;
double result;
scanf("%d",&T);
for(int i=0;i<T;i++)
{
scanf("%d",&n);
result = 0.0;
for(int j=1;j<=n;j++)
{
result += log10(j);
}
printf("%d\n",(int)result+1);
}
return 0;
}


看到有个使用Java 斯特林公式的同学,也可以参考下,不推荐。(本质上还是用到了 (公式= 正整数a的位数等于(int)log10(a) + 1),只是计算阶乘的地方使用了斯特林公式,感兴趣的同学可以百度了解下)

import java.util.Scanner;

public class Main
{
public static void main(String[] args)
{
Scanner in = new Scanner(System.in);
int n = in.nextInt();
for (int i = 0; i < n; i++)
{
int num = in.nextInt();
System.out.println((int) (Math.log10(Math.sqrt(2 * Math.PI * num)) + num* Math.log10(num / Math.E)) + 1);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: