您的位置:首页 > 其它

POJ 2387 Til the Cows Come Home(最短路径,模板题)

2016-08-04 17:35 344 查看
Til the Cows Come Home

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44115 Accepted: 14995
Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various
lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100


Sample Output
90


Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

Source

USACO 2004 November

题意:

最短路的基础题。

直接敲代码吧。记得筛选重边,另外,学长的教学代码是不是有问题。。。。

代码1

自己照着学长的模板敲得,学长说的是map[1]
貌似:

#include<stdio.h>
#include<string.h>
const int MYDD=1103;
const int INF=0x3f3f3f3f;

int map[MYDD][MYDD];
bool vis[MYDD];
int dis[MYDD];
void dijk(int x) {
memset(vis,false,sizeof(vis));
vis[1]=true;
for(int i=2; i<=x; i++)
dis[i]=map[1][i];
for(int i=1; i<=x; i++) {
int Tp=INF,k=-1;
//每次找出最小的距离加入到集合
for(int j=1; j<=x; j++) {
if(!vis[j]&&dis[j]<Tp) {
Tp=dis[j];//临时变量记录最短路
k=j;//选择的节点编号,
}
}

vis[k]=true;
for(int j=1; j<=x; j++)
if(!vis[j]&&dis[j]>dis[k]+map[k][j])
dis[j]=dis[k]+map[k][j];
}
}

int main() {
int N,T;
scanf("%d%d",&T,&N);
memset(map,INF,sizeof(map));
while(T--) {
int u,v,w;
scanf("%d%d%d",&u,&v,&w);
if(map[u][v]>w||map[v][u]>w)//重边的筛选
map[u][v]=map[v][u]=w;
}
dijk(N);
printf("%d\n",dis
);
return 0;
}

代码2,自己搜罗后敲的,总是运行出错,才发现 T N 键入反了:
#include<stdio.h>
#include<string.h>
const int MYDD=1103;
const int INF=0x3f3f3f3f;

int map[MYDD][MYDD];
bool vis[MYDD];
int dis[MYDD];
void dijk(int s,int n) {
memset(vis,false,sizeof(vis));
vis[s]=true;
for(int i=1; i<=n; i++)
dis[i]=map[s][i];
for(int i=1; i<=n-1; i++) {
int Tp=INF,k=-1;
//每次找出最小的距离加入到集合
for(int j=1; j<=n; j++) {
if(!vis[j]&&dis[j]<Tp) {
Tp=dis[j];//临时变量记录最短路
k=j;//选择的节点编号,
}
}

vis[k]=true;
for(int j=1; j<=n; j++)
if(!vis[j]&&dis[j]>dis[k]+map[k][j])
dis[j]=dis[k]+map[k][j];
}
}

int main() {
int N,T;
scanf("%d%d",&T,&N);
memset(map,INF,sizeof(map));
while(T--) {
int u,v,w;
scanf("%d%d%d",&u,&v,&w);
if(map[u][v]>w||map[v][u]>w)//重边的筛选
map[u][v]=map[v][u]=w;
}
dijk(N,N);
printf("%d\n",dis[1]);
return 0;
}

后:
****************

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: