您的位置:首页 > 其它

poj2387——Til the Cows Come Home(最短路径)

2016-01-31 11:18 357 查看
Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

Line 1: Two integers: T and N

Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5

1 2 20

2 3 30

3 4 20

4 5 20

1 5 100

Sample Output

90

Dijkstra算法模板

#include<iostream>
#include<cstring>
#include<stdio.h>
#define maxcost 100000
#define max 1010
using namespace std;
int n,map[max][max],vis[max],dist[max];
void dij(int v)
{
int min,i,j,k,dis;
for(i=1; i<=n; ++i)
{
dist[i]=map[v][i];
vis[i]=0;
}
vis[i]=1;
dist[i]=0;
for(i=1; i<=n; ++i)
{
min=maxcost;
k=v;
for(j=1; j<=n; ++j)
if(dist[j]<min&&!vis[j])  //找出当前距点v最近的没被遍历过的点k
{
min=dist[j];
k=j;
}
vis[k]=1; //然后这个点就被遍历过了
for(j=1;j<=n;++j)
{
dis=dist[k]+map[k][j];
if(!vis[j]&&dist[j]>dis&&map[k][j]!=maxcost)
dist[j]=dis;
}
}
printf("%d\n",dist
);
}
int main()
{
int t,i,j,a,b,c;
while(~scanf("%d%d",&t,&n))
{
for(i=1; i<=n; ++i)
for(j=1; j<=n; ++j)
map[i][j]=maxcost;
while(t--)
{
scanf("%d%d%d",&a,&b,&c);
if(c<map[a][b])
{
map[a][b]=c;
map[b][a]=c;
}
}
dij(1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: