您的位置:首页 > 其它

POJ 2387 Til the Cows Come Home Dijkstra求最短路径

2017-07-31 20:03 459 查看

Til the Cows Come Home

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

题意:给你一个图,途中每一条边都带有权值(路径长度),求从1到n的最短路径。
思路:单元最短路问题,首先想到Dijkstra。在这里把最基础的Dij O(n^2)与邻接表存图、堆优化的Dij O((n+m)logn)作个比较。
ps:史上最坑题!没有之一!首先是题目和样例的t、n顺序不同很容易误导爆RE。。再一个就是重 边 问 题!基础Dij会WA。。这题还有数据范围也...总之还是先把基础打好。



基础Dij:

#include<stdio.h>
#include<string.h>
#include<limits.h>

int a[1010][1010];
int dis[1010],b[1010];
int n;

int min(int x,int y)
{
return x<y?x:y;
}

void dij(int k)
{
int i,j,mind,minj;
memset(b,0,sizeof(b));
for(i=1;i<=n;i++){
dis[i]=INT_MAX;
}
dis[k]=0;
for(i=1;i<n;i++){
mind=INT_MAX;
for(j=1;j<=n;j++){
if(!b[j]&&dis[j]<mind){
mind=dis[j];
minj=j;
}
}
b[minj]=1;
for(j=1;j<=n;j++){
if(!b[j]&&a[minj][j]>=0){
dis[j]=min(dis[j],dis[minj]+a[minj][j]);
}
}
}
}

int main()
{
int t,x,y,z;
memset(a,-1,sizeof(a));
scanf("%d%d",&t,&n);
while(t--){
scanf("%d%d%d",&x,&y,&z);
if(a[x][y]!=-1){
if(z<a[x][y]){
a[x][y]=z;
a[y][x]=z;
}
}
else{
a[x][y]=z;
a[y][x]=z;
}
}
dij(1);
printf("%d\n",dis
);
return 0;
}


优化Dij:

#include<stdio.h>
#include<string.h>
#include<limits.h>
#include<vector>
#include<queue>
using namespace std;

struct Node{
int v,w;
friend bool operator<(Node a,Node b)
{
return a.w>b.w;
}
}node;

vector<Node> a[1005];
int dis[1005];
int n;

void dij(int k)
{
int v1,v2,i;
priority_queue<Node> q;
dis[k]=0;
node.w=0;
node.v=k;
q.push(node);
while(q.size()){
v1=q.top().v;
q.pop();
for(i=0;i<a[v1].size();i++){
v2=a[v1][i].v;
if(dis[v2]>dis[v1]+a[v1][i].w){
dis[v2]=dis[v1]+a[v1][i].w;
node.w=dis[v2];
node.v=v2;
q.push(node);
}
}
}
}

int main()
{
int t,x,y,z,i;
scanf("%d%d",&t,&n);
for(i=1;i<=n;i++){
a[i].clear();
dis[i]=INT_MAX;
}
while(t--){
scanf("%d%d%d",&x,&y,&z);
node.w=z;
node.v=y;
a[x].push_back(node);
node.v=x;
a[y].push_back(node);
}
dij(1);
printf("%d\n",dis
);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: