您的位置:首页 > 其它

Little Zu Chongzhi's Triangles

2016-04-09 19:17 357 查看
Zu Chongzhi (429�500) was a prominent Chinese mathematician and astronomer during the Liu Song and Southern Qi Dynasties. Zu calculated the value ofπ to the precision of six decimal places and for a thousand years thereafter no subsequent mathematician computed
a value this precise. Zu calculated one year as 365.24281481 days, which is very close to 365.24219878 days as we know today. He also worked on deducing the formula for the volume of a sphere.

It is said in some legend story books that when Zu was a little boy, he liked mathematical games. One day, his father gave him some wood sticks as toys. Zu Chongzhi found a interesting problem using them. He wanted to make some triangles by those sticks, and
he wanted the total area of all triangles he made to be as large as possible. The rules were :

1) A triangle could only consist of 3 sticks.

2) A triangle's vertexes must be end points of sticks. A triangle's vertex couldn't be in the middle of a stick.

3) Zu didn't have to use all sticks.

Unfortunately, Zu didn't solve that problem because it was an algorithm problem rather than a mathematical problem. You can't solve that problem without a computer if there are too many sticks. So please bring your computer and go back to Zu's time to help
him so that maybe you can change the history.
 

Input

There are no more than 10 test cases. For each case:

The first line is an integer N(3 <= N<= 12), indicating the number of sticks Zu Chongzhi had got. The second line contains N integers, meaning the length of N sticks. The length of a stick is no more than 100. The input ends with N = 0.
 

Output

For each test case, output the maximum total area of triangles Zu could make. Round the result to 2 digits after decimal point. If Zu couldn't make any triangle, print 0.00 .
 

Sample Input

3
1 1 20
7
3 4 5 3 4 5 90
0

 

Sample Output

0.00
13.64
这道题用状态压缩dp,一个状态i(用二进制表示)可以转移到若干个状态j,其中状态j相当与从i中拿出三条边组成三角,其中dp[i]=max(dp[i],dp[j]+calArea(a,b,c));这道题做的时候窝又把double声明成了int,wa一次....,然后还有一次是忘了把dp归零...下面是AC代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
double max(double a,double b){
return a>b?a:b;
}
int valid(int a,int b,int c){
if(a>=b+c)
return 0;
if(b>=a+c)
return 0;
if(c>=a+b)
return 0;
return 1;
}
double calArea(int a,int b,int c){
double p=(a+b+c)/2.0;
return sqrt(p*(p-a)*(p-b)*(p-c));
}
double dp[5000];
int main(){
int n,i,j,k,tail,stick[20],place[50];
double ans;
while(scanf("%d",&n)&&n){
ans=0.0;
tail=0;
memset(dp,0,sizeof(dp));
for(i=0;i<n;i++)
scanf("%d",&stick[i]);
for(i=0;i<(1<<n);i++){
for(j=0;j<(1<<n);j++){
if((i|j)!=i)
continue;
tail=0;
for(k=0;k<n;k++){
if((i&(1<<k))!=0&&(j&(1<<k))==0){
place[tail++]=stick[k];
}
}
if(tail==3){
if(valid(place[0],place[1],place[2]))
dp[i]=max(dp[i],dp[j]+calArea(place[0],place[1],place[2]));
}
}
}
for(i=0;i<(1<<n);i++)
ans=max(ans,dp[i]);
printf("%.2lf\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划